Pages may be slow loading

Incident Report for Holaspirit by Talkspirit

Resolved

This incident has been resolved.
Posted May 07, 2024 - 09:12 UTC

Investigating

The web application is currently experiencing a higher than normal amount of load, and may be causing pages to be slow or unresponsive. We're investigating the cause and will provide an update as soon as possible.
Posted May 07, 2024 - 07:47 UTC